«

»

jan 16

OAV-46511: missing plugin for trail at agent on host

This post is also available in: English

Estes dias, depois de instalar um novo agente do AV e realizar a configuração inicial de um novo audit trail, comecei a receber um erro estranho “OAV-46511: missing plugin for trail at agent on host” como na imagem abaixo:

O agente tinha acabado de ser implantado então não tinha razão para ele não incluir os plugins. Após pesquisar um pouco, encontrei no MOS que existe um Bug 17958893 com sintomas similares e cuja resolação é a seguinte:

SOLUTION

  1. Stop the Agent. Make sure that no processes are running from the Agent home.
  2. Log into the AVDF interface and stop any Audit Trail that is using this Agent. These should already have been be stopped when the Agent was stopped, but check again.
  3. Navigate to the Host tab, and select the Host named in the error. Click “Deactivate”. Select it again, and click “Activate”. (A new key should be created.)
  4. Navigate to the Host -> Agent page, and re-download agent.jar to the target Host.
  5. Create a new home (or remove all files from the old Agent home), then redeploy the Agent:
    java -jar agent.jar -d <AGENT_HOME>
  6. Start the Agent.
    cd <AGENT_HOME>/bin
    ./agentctl start -k

Vamos tentar..

Agente parado…

Desativando o host:

Reativo o host no AV e então inicio o agente..

Tentando adicionar o audit trail novamente..

E funciona! Agora posso finalmente continuar com a configuração do AV.

Gostou? Não deixe de comentar ou dar um like. Abraços e até a próxima!

 

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Você pode usar estas tags e atributos de HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">